CloverETL is now CloverDX - Learn Why

Error reading an excel data file

Support questions related to CloverDXServer

Posts: 1
Joined: Thu Jan 22, 2015 10:07 pm

Error reading an excel data file

Postby charikrv » Thu Jan 22, 2015 10:26 pm

I have a graph that reads an excel data file. The input xlsx has only one sheet of data. The graph works fine in my desktop computer. But when I ftp it to the Linux server and run it, it throws the following error:
Node READ_PART_SHEET error details:
Element [READ_PART_SHEET:Read Part Sheet]-Component pre-execute initialization failed.
... the file will be ignored caused by: There is no sheet conforming sheet pattern
My Desktop Version:
Server version

I tried using the XSL reader. It did not work. I changed it to spreadsheet reader. Still, it gives the same error.

What is causing this error?

Posts: 372
Joined: Thu Jan 12, 2012 9:10 am

Re: Error reading an excel data file

Postby kubosj » Fri Jan 23, 2015 10:09 am

Hi Chari,

Please do not mix Server and Designer version - such combination is not supported because graphs are not compatible. Also Server API changes during time. So that may be one issue.

Other problem may be field "Sheet" of SpreadsheetReader. There you can specify which sheets should be read (please consult documentation). Maybe your "Sheet" does not correspond with sheet name in file. If I do that intentionally I get same exception.

I hope this helps.
Jaroslav Kubos
CloverCARE Support
CloverETL | Rapid Data Integration

Visit us online at