Unable to resolve parameter

Support/help with CloverETL (4.9) and CloverDX (5.0 or newer) implementation problems

srirams
Posts: 4
Joined: Mon Nov 18, 2013 11:07 pm

Unable to resolve parameter

Postby srirams » Fri Jul 10, 2020 7:33 am

hi

We are trying to convert our clover 4.4 to 5.6.

We use connection properties through workspace parameter file (like user id, encrypted password)

When we connect DB, it says 'Unable to resolve parameter'

1. Should I change it to dynamic parameter?
2. How to use for encrypted db password?

Thanks
Sriram.

jandikovae
Posts: 64
Joined: Fri Nov 04, 2016 8:51 am

Re: Unable to resolve parameter

Postby jandikovae » Fri Jul 17, 2020 8:32 pm

Hi Sriram,

The dynamic parameter is used when the value of the parameter changes in time, for example, if you use function today() which returns different value every day.

To find out the solution in your issue I might need more information:

1.) Are all your projects suddenly unable to resolve secure parameters created in your original version? If so, the issue might be caused by Master Password disparity. The Secure Parameter (the functionality that allows encrypting parameter values) has to be initialized by setting up Master Password on the server level. In the 4.4 version, you can find it in Configuration -> Secure Parameters. After doing that, every secure parameter is then encrypted using this Master Password. To properly use already encrypted parameter values in an upgraded environment, you have to set the same Master Password in your new Server version (Configuration -> Setup -> Security -> click Set Master Password).

2.) Does it appear only when it comes to one specific .prm file? If so, please try to rebuild the .prm file from a scratch. To be able to copy and use the parameter file across projects and sandboxes, I would recommend using a new file (not the default workspace.prm). Go to the Outline pane and choose Parameters -> New parameter file and click OK.
newparamfile.PNG
newparamfile.PNG (31.95 KiB) Viewed 792 times

In the next step, select location within your project, it can be even the parent folder. Then double-click the file in the navigation pane and reenter all parameters necessary.
paramfilesetup.PNG
paramfilesetup.PNG (34.13 KiB) Viewed 792 times


3.) Also please make sure there is no duplicity in parameter names in the project path. I mean, open the Workspace.prm as well and make sure you delete possible parameters that have the same name as the newly created ones in the separate parameter file.

If this is not helpful, please let me know more information about your issue. Could you, for example, provide me with the exact error message you can see? Thanks, Eva
---
Eva Jandikova
CloverCARE Support
CloverDX

Visit us online at http://www.cloverdx.com


cron