Elastic Search Reader/Writer

Support/help with CloverETL (4.9) and CloverDX (5.0 or newer) implementation problems

nathan888
Posts: 1
Joined: Sun Sep 23, 2018 6:18 pm

Elastic Search Reader/Writer

Postby nathan888 » Sun Sep 23, 2018 6:36 pm

Hi,
I'm running version 4.9.1.016.
I'm trying to add the Elastic Search JDBC driver (x-pack-sql-jdbc-6.4.0.jar) as a new DB connection.
I'm getting the following error meessage:
"Failed to load class from jar C:/ElasticJDBC/x-pack-sql-jdbc-6.4.0.jar - unsupported class version."

Has someone succeeded in adding Elastic Seach connectivity ?
Would like to avoid Custom Java Connectivity if possible.

Thanks

vazquezrosariop
Posts: 151
Joined: Mon Feb 29, 2016 5:33 pm

Re: Elastic Search Reader/Writer

Postby vazquezrosariop » Wed Oct 03, 2018 5:10 pm

Hi nathan,

The reason the jar is failing to load in the db connections is because it requires Java 9 to work properly and I suspect you are using Java 7 or 8. That being said, currently we officially support Java 9 in CloverDX 5.0, in the case of older version most things should work even with Java 9, but there might be some minor incompatibilities. I would recommend upgrading to CloverDX 5.0 if possible.
---
Pedro X. Vazquez Rosario
CloverCARE Support
CloverDX

Visit us online at http://www.cloverdx.com


cron