DBExecute graphs not working with JNDI connections

Support/help with CloverETL (4.9) and CloverDX (5.0 or newer) implementation problems

ramiro
Posts: 19
Joined: Fri Aug 08, 2014 1:13 am

DBExecute graphs not working with JNDI connections

Postby ramiro » Sat Sep 12, 2015 12:06 am

I am using CloverETL Server 3.5.2.12/12

When I link a DBExecute graph to a JNDI pool connection resource, the sql query doesn't get executed, and it just times out. If I switch to regular postgresql driver connections, the same sql works just fine.

Looks like DBInputTable works just fine (with the same JNDI resource). Is there a reason why DBExecute graphs won't work with it?

slechtaj
Posts: 192
Joined: Wed Aug 15, 2012 8:18 am

Re: DBExecute graphs not working with JNDI connections

Postby slechtaj » Wed Sep 16, 2015 12:46 pm

Hi Ramiro,

Is this the same issue as troubleshooting a postgresql JNDI connection, or is there another context in this case?
Jan Slechta
CloverCARE Support
CloverETL | Rapid Data Integration

Visit us online at http://www.cloveretl.com

How to speed up communication with CloverCARE support

ramiro
Posts: 19
Joined: Fri Aug 08, 2014 1:13 am

Re: DBExecute graphs not working with JNDI connections

Postby ramiro » Wed Sep 16, 2015 4:53 pm

Hi Jan,

Same issue. The reason I posted there first was because I though my JNDI setup was wrong.

Later I realize the problem was the combination of a DBExecute graph and a JNDI connection that didn't work (all other graphs that involve db connections seem to be ok). So I was thinking I may have a better chance to find the answer in a forum different that the Clover Server. That's why I ended up duplicating the question here.

Sorry about the confusion! I'll continue the conversation in the other forum. Looks like there are some responses there now. Thanks.