# ERROR caused by: The size of data buffer is only 4096. Set a

**URL:** <https://forum.cloverdx.com/t/error-caused-by-the-size-of-data-buffer-is-only-4096-set-a/520>\
**Category:** CloverDX Platform\
**Created:** [May 6, 2009, 12:00am UTC](https://forum.cloverdx.com/t/error-caused-by-the-size-of-data-buffer-is-only-4096-set-a/520 "2009-05-06T00:00:00Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![avackova](https://avatars.discourse-cdn.com/v4/letter/a/65b543/32.png) [@avackova](https://forum.cloverdx.com/u/avackova)\
**Post date:** [May 6, 2009, 12:00am UTC](https://forum.cloverdx.com/t/error-caused-by-the-size-of-data-buffer-is-only-4096-set-a/520/1 "2009-05-06T00:00:00Z")

</div>

Sometimes graph execution fails with error like this:

```auto

ERROR caused by: The size of data buffer is only 4096. Set appropriate parameter in defaultProperties file.

```

In such case you should increase the value of proper property, which is stored in defaultProperties file, which is located in “org/jetel/data/” subdirectory of CloverETL engine. You can create your own properties file with overridden properties you need to change only and run graph with -config switch. Full info can be found in [CloverETL framework run time constants](http://wiki.cloveretl.org/doku.php?id=compile%5Ftime%5Fconstants)
