# Configure Clover ETL server conn to oracle database failed

**URL:** https://forum.cloverdx.com/t/configure-clover-etl-server-conn-to-oracle-database-failed/1140
**Category:** CloverDX Platform
**Created:** [December 6, 2012, 12:00am UTC](https://forum.cloverdx.com/t/configure-clover-etl-server-conn-to-oracle-database-failed/1140 "2012-12-06T00:00:00Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![roy2090](https://avatars.discourse-cdn.com/v4/letter/r/3e96dc/32.png) [@roy2090](https://forum.cloverdx.com/u/roy2090)
#### Post date: [December 6, 2012, 12:00am UTC](https://forum.cloverdx.com/t/configure-clover-etl-server-conn-to-oracle-database-failed/1140/1 "2012-12-06T00:00:00Z")

</div>

Hi Experts

I installed clover ETL server on Linux64, and try to configure it connect to oracle database according to Doc description

Change the config.properties under …/WEB-INF as following:

jdbc.driverClassName=oracle.jdbc.OracleDriver  
jdbc.url=jdbc:oracle:thin:@host:1521:db  
jdbc.username=user  
jdbc.password=pass  
jdbc.dialect=org.hibernate.dialect.Oracle9Dialect

I also add jdbc jar into CLASSPATH. but [http://host:8000/clover](http://host:8000/clover) can not work as below error

HTTP Status 404 -

type Status report

message

description The requested resource is not available.

Apache Tomcat/6.0.36

Can you please give me some direction for fixing this issue. thanks

---

<div class="post-metadata">

### Author: ![slechtaj](https://avatars.discourse-cdn.com/v4/letter/s/59ef9b/32.png) [@slechtaj](https://forum.cloverdx.com/u/slechtaj)
#### Post date: [December 6, 2012, 4:44pm UTC](https://forum.cloverdx.com/t/configure-clover-etl-server-conn-to-oracle-database-failed/1140/2 "2012-12-06T16:44:32Z")

</div>

Hi Roy,

I can see two potential causes:

- It is highly recommended to set context parameters in context configuration file instead of writing it into config.properties under _/WEB-INF_ directory. For more information about parameters configuration, please refer to [http://doc.cloveretl.com/documentation/UserGuide/index.jsp?topic=/com.cloveretl.gui.docs/docs/index.html](http://doc.cloveretl.com/documentation/UserGuide/index.jsp?topic=/com.cloveretl.gui.docs/docs/index.html).

- I am not sure where you put the jar file with JDBC driver, since this should be placed in _/WEB-INF/lib_.

Could you please follow aforementioned steps to set the properties, and check where you loaded the jar file?

In case you still cannot connect to your database, it would be helpful if you send us your Clover log files (_[tomcat\_home]/temp/cloverlogs/_).

Regards,  
Jan

---

<div class="post-metadata">

### Author: ![David\_Hlidek](https://avatars.discourse-cdn.com/v4/letter/d/58f4c7/32.png) [@David\_Hlidek](https://forum.cloverdx.com/u/David_Hlidek)
#### Post date: [December 7, 2012, 8:07am UTC](https://forum.cloverdx.com/t/configure-clover-etl-server-conn-to-oracle-database-failed/1140/3 "2012-12-07T08:07:22Z")

</div>

Hi Roy,

just small correction - put your JDBC driver into [tomcat\_home]/lib and NOT into [tomcat\_home]/webapps/cover/WEB-INF/lib as Jan suggested.

General rule is that user should not change anything in [tomcat\_home]/webapps because any further deploy will rewrite any changes.
