# CloverETL server fails to start after DB configuration change to Oracle 11g/12c

**URL:** https://forum.cloverdx.com/t/cloveretl-server-fails-to-start-after-db-configuration-change-to-oracle-11g-12c/1795
**Category:** CloverDX Platform
**Created:** [September 20, 2016, 12:00am UTC](https://forum.cloverdx.com/t/cloveretl-server-fails-to-start-after-db-configuration-change-to-oracle-11g-12c/1795 "2016-09-20T00:00:00Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![jzhu](https://avatars.discourse-cdn.com/v4/letter/j/f19dbf/32.png) [@jzhu](https://forum.cloverdx.com/u/jzhu)
#### Post date: [September 20, 2016, 12:00am UTC](https://forum.cloverdx.com/t/cloveretl-server-fails-to-start-after-db-configuration-change-to-oracle-11g-12c/1795/1 "2016-09-20T00:00:00Z")

</div>

Initially, the DB configuration (for both Oracle DB 11g/12c) worked after fiddling around with server v.4.2.1 (Tomcat).  
I restarted from fresh, in order:  
(1) stop and remove 4.2.1,  
(2) reinstall 4.3.0,  
(3) drop all (39) tables in the DB,  
(4) start 4.3.0,  
(5) add license  
(6) configure DB (Oracle), validate and save  
(7) shutdown and start 4.3.0  
(8) server web interface shows:  
CloverETL Server initialization has failed  
Root exception  
java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist  
Stack trace  
javax.persistence.PersistenceException: org.hibernate.exception.SQLGrammarException: could not extract ResultSet  
…

Check the DB, there are only 20 tables (usually 39), including one new table (GRAPH\_EVENt\_LISTENER) which does not exist among the 39 tables.

Repeat the procedure with 4.2.1 (instead of 4.3.0 above), and fails in the same way as above.  
I cannot remember how I got the DB working in the first place – it was not straight forward.

Any idea what caused the problem?

Thanks

---

<div class="post-metadata">

### Author: ![PedroVazquezRosario](https://avatars.discourse-cdn.com/v4/letter/p/ed8c4c/32.png) [@PedroVazquezRosario](https://forum.cloverdx.com/u/PedroVazquezRosario)
#### Post date: [September 21, 2016, 1:57pm UTC](https://forum.cloverdx.com/t/cloveretl-server-fails-to-start-after-db-configuration-change-to-oracle-11g-12c/1795/2 "2016-09-21T13:57:48Z")

</div>

Hi jzhu,

Just a overview of how you resolved this issue, there was an object(sequence) left in the database after all tables were dropped causing the problem. The issue was solved by dropping the sequence from the database.
