Search found 163 matches

by jurban
Mon Sep 24, 2007 10:31 am
Forum: CloverDX (formerly CloverETL) Support
Topic: Problem with graph component enabled property
Replies: 2
Views: 3002

Hello,
could you please post the graph?

Thanks!
Jaro
by jurban
Wed Sep 19, 2007 2:39 pm
Forum: CloverDX (formerly CloverETL) Support
Topic: DTD of custom component definition file
Replies: 5
Views: 5366

Hi, unfortunately the iconPath attribute does not work correctly for custom components. More specifically, the root of the iconPath is somewhere inside the Clover GUI plugin jar file. So, you can can set the iconPath only to the paths of icons stored in the jar file. Unfortunately, because of code o...
by jurban
Wed Sep 19, 2007 9:12 am
Forum: CloverDX (formerly CloverETL) Support
Topic: DTD of custom component definition file
Replies: 5
Views: 5366

I've jsut checked, and unfortunately you cannot add your own component category. You must use one of these category names:

- readers
- writers
- joiners
- transformers
- others
- userDefined
by jurban
Wed Sep 19, 2007 8:59 am
Forum: CloverDX (formerly CloverETL) Support
Topic: DTD of custom component definition file
Replies: 5
Views: 5366

Hi, look in the chapter 5 of the Clover GUI manual, which can be found here: http://wiki.clovergui.net/docs/cloveretl.gui.doc-20060905.pdf There is the DTD you're looking for, and an example component definition file. The DTD is a little bit outdated, but it will work. New features (available in clo...
by jurban
Tue Sep 18, 2007 8:50 am
Forum: CloverDX (formerly CloverETL) Support
Topic: aggregates
Replies: 1
Views: 2850

Hi, which version of clover are you using. In the 2.2 version, the aggregate component was updated (the aggregate documentation on the wiki is out of date, that will be fixed). The stddev() function should work, e.g.: $ouput_field:=stddev($input_field) Please note that standard deviation cannot be c...
by jurban
Fri Sep 07, 2007 3:16 pm
Forum: CloverDX (formerly CloverETL) Support
Topic: Issue with parameterized metadata file
Replies: 8
Views: 7110

post the metadata file too, please. thanks...
by jurban
Fri Sep 07, 2007 2:30 pm
Forum: CloverDX (formerly CloverETL) Support
Topic: Issue with parameterized metadata file
Replies: 8
Views: 7110

Hi,
this should work. Which version of GUI and engine are you using? Are you sure that the metadata file is valid? The comment for the metadata parameter ("/* ... */) is not in the graph XML file, I suppose? You could post the graph and the metadata file here.

Jaro
by jurban
Wed Sep 05, 2007 3:57 pm
Forum: CloverDX (formerly CloverETL) Support
Topic: CloverETL Engine 2.2 slower than 2.1.3
Replies: 14
Views: 8658

Hello,
we will investigate the slowdown, but it might take some time. Thanks for your input!

Jaro
by jurban
Tue Sep 04, 2007 4:23 pm
Forum: CloverDX (formerly CloverETL) Support
Topic: CloverETL Engine 2.2 slower than 2.1.3
Replies: 14
Views: 8658

The 2.2.1 bugfix release should be out in 1 or 2 weeks. The release will contain the bugfix to your issue with the batchmode.

Jaro
by jurban
Tue Sep 04, 2007 3:44 pm
Forum: CloverDX (formerly CloverETL) Support
Topic: CloverETL Engine 2.2 slower than 2.1.3
Replies: 14
Views: 8658

Hi, I think I know what's causing the error with the batchmode (it is fixed in a newer yet unrealeased engine version). I think that as a workaround, you should connect the first output port (port 0) of all DB_OUTPUT_TABLE components with some TRASH component, and assign the connector the same metad...
by jurban
Tue Sep 04, 2007 3:00 pm
Forum: CloverDX (formerly CloverETL) Support
Topic: CloverETL Engine 2.2 slower than 2.1.3
Replies: 14
Views: 8658

I suspect that the slowdown is caused by the turned off batchmode. I tried the batchmode, but it works for me. Could you please post the stacktrace of the NullPointerException?

Thanks!
by jurban
Tue Sep 04, 2007 1:54 pm
Forum: CloverDX (formerly CloverETL) Support
Topic: CloverETL Engine 2.2 slower than 2.1.3
Replies: 14
Views: 8658

Hello,
could you please describe the process which now takes longer to complete? Which components are you using etc.?

Thanks!
Jaro
by jurban
Tue Sep 04, 2007 12:56 pm
Forum: CloverDX (formerly CloverETL) Support
Topic: multiple monitors
Replies: 1
Views: 3153

Hello,
I was unable to reproduce the problem. Could you please post more information about your setup, especially your operating system? Which version of Clover GUI are you using (I suppose 1.7)? Thanks!

Jaro

cron